Help with 763 whinning while turning

Help Support SkidSteer Forum:

Mike763

Member
Joined
Mar 28, 2007
Messages
10
I took my 763 in to bobcat to have the neutral and linkage adjusted. I also had a flow test done, they said everything was good. Now my machine seems to really wine When I turn. when I push the right hand control it sounds like a valve is open and its leaking. The machine still seems to work Ok, But it doesn't sound good. thanks Mike
 

skidsteer.ca

Well-known member
Joined
Jan 20, 2006
Messages
3,853
When you drive it full speed forward or reverse does it go in a straight line? (assuming your tires are equal size and pressure)
When you le go of the steering levers it stop, does not creep forward ,backward or spin slowly in a circle?
Because those are about the only things the neutral adjustment can affect.
Did they flow test the hydraulic pump, left and right hydrostatic pumps or all 3?
The only thing I can think is if they did not conect a line back up correctly after testing the pumps, but that would be resonable unlikely.
Ken
 

Tazza

Moderator
Staff member
Joined
Dec 7, 2004
Messages
16,843
When you drive it full speed forward or reverse does it go in a straight line? (assuming your tires are equal size and pressure)
When you le go of the steering levers it stop, does not creep forward ,backward or spin slowly in a circle?
Because those are about the only things the neutral adjustment can affect.
Did they flow test the hydraulic pump, left and right hydrostatic pumps or all 3?
The only thing I can think is if they did not conect a line back up correctly after testing the pumps, but that would be resonable unlikely.
Ken
If they did a flow and pressure test could it be air stuck in the system? How long have you run the machine for since it was *fixed*? Air can take a little while to go, but not too long.
 
OP
OP
M

Mike763

Member
Joined
Mar 28, 2007
Messages
10
If they did a flow and pressure test could it be air stuck in the system? How long have you run the machine for since it was *fixed*? Air can take a little while to go, but not too long.
I checked My receipt, there was no information about the flow test. The mechanic told me everything passed the test. My receipt said I was suppose to get a print out of the results, which I didn't. I will call bobcat on monday and find out if they tested everything. I Have put about 20 hrs on the machine since it was fixed. Thanks Mike
 
Top