Tl150 supertrak

Help Support SkidSteer Forum:

Simplelife

Member
Joined
Dec 19, 2019
Messages
20
I bought one back in January , pretty stout machine , sold my asv rc85 .. big upgrade .. but was hoping a member on here has experience with one.. as I went to connect my grapple and it seems when I use the pedal or joystick buttons it pressurize my hi flow line as well as the low flow where the grapple is connected .. and I can’t get my grapple to open or close another issue is when I use my bush hog I can’t get the 1 way flow to work and I have to use my foot on the pedal to work it .. bother the detent light and 1way2way light works .. high flow works… I checked the solenoids and they seemed fine .. hope someone can point me to the right direction ..
 

Simplelife

Member
Joined
Dec 19, 2019
Messages
20
This is the supertrak
 

Attachments

  • D90163D5-4B8E-45FE-ABD9-8C9B0B1EFFB6.jpeg
    D90163D5-4B8E-45FE-ABD9-8C9B0B1EFFB6.jpeg
    4.8 MB · Views: 20

Simplelife

Member
Joined
Dec 19, 2019
Messages
20
I’ve seen that page before.. I took out my solenoids and cleaned them all. I put on the grapple again and now it opens the grapple maybe 1/4 up and down .. but no further.. but while doing this it also puts pressure on my hi flow line .. I guess I’m getting a little closer .. any ideas ?
 

ddbackhoe

Active member
Joined
Feb 22, 2016
Messages
35
So if you have all the switches in the right positions, what is turning hiflow on? Does the hiflow light illuminate?
If they do, I would backtrack the signal and figure out where it is coming from.
 

Simplelife

Member
Joined
Dec 19, 2019
Messages
20
So if you have all the switches in the right positions, what is turning hiflow on? Does the hiflow light illuminate?
If they do, I would backtrack the signal and figure out where it is coming from.
To turn on hi flow , first you have to turn detent on , left joystick press the left top button , it will start spinning mulcher , then by key switch there’s a green button you have to turn on , then that engages the hi flow ..

But I still can’t figure out how to use the grapple .. like if wants to open buy it only moves a little then stops .. but it’s sending oil thru the high flow line as well
 

ddbackhoe

Active member
Joined
Feb 22, 2016
Messages
35
To turn on hi flow , first you have to turn detent on , left joystick press the left top button , it will start spinning mulcher , then by key switch there’s a green button you have to turn on , then that engages the hi flow ..

But I still can’t figure out how to use the grapple .. like if wants to open buy it only moves a little then stops .. but it’s sending oil thru the high flow line as well
as far as I know, when high flow ports are enabled, standard flow is disabled. Which ports did you connect the grapple to?
 

Simplelife

Member
Joined
Dec 19, 2019
Messages
20
as far as I know, when high flow ports are enabled, standard flow is disabled. Which ports did you connect the grapple to?
There’s 2 large quick connects on top of the boom which is the high flow , and there’s 2 smaller quick connects which is the low flow on the inside of boom , I connect the grapple to the smaller ones .. and you can see the grapple just barely open .. is there a valve that happens to get stuck partially some where that happens to make the low flow not work so well ..? When I use my bush hog it works fine ..
 

Simplelife

Member
Joined
Dec 19, 2019
Messages
20
So if you have all the switches in the right positions, what is turning hiflow on? Does the hiflow light illuminate?
If they do, I would backtrack the signal and figure out where it is coming from.
All the switches are not illuminated, they are in off position . Still trying to figure it out.. Today I’m doing Maintence on it .. other then that this machine is a beast ..
 
Top