hydraulic problem

Help Support SkidSteer Forum:


New member
Jan 11, 2007
new skid steer owner/user.... i used my old(1970ish) L555 for doing misc stuff around the house and it worked fantastic..everything was strong and the hydraulics had no problem..other than a hub? leak on the right front wheel. i just moved and the skid steer sat in my trailer for about 5 months. i started it up and the bucket had no control whatsoever. i drove it out of the trailer and then i had no control of the wheels. i noticed the "hydraulic charge" light is now on. it turned off very briefly and i was able to move it (still no bucket capability) real quick, but then it stopped working and the light was on again. when i bought the machine i didn't (and still don't i guess) know anything about it...the hydraulic "oil" is a milky/creamy white-ish color. i didn't think anything of it when i bought it, figuring it was just a special type of hyd. fluid. as i mentioned, it worked great for a few months as i purchased it. just looking for some answers/solutions! i haven't tried to start it up and move it in a couple days. thanks in advance for any help!


Well-known member
Dec 28, 2006
those older machines were prown to have water entering the hydraulic resevoirs through the chain inspection plate on top of the resevoirs this causes the oil to turn to a creamy white colour. you either buggered the hydraulic pump or if it was cold enough to freese snap the shaft off the hydraulic pump! there is also a strainer under the seat that you can remove and check if the screen is abstructed.

Latest posts