How to repair leaking lift cylinders?

Help Support SkidSteer Forum:

cchardwick

Well-known member
Joined
Jan 25, 2007
Messages
52
Hi Everyone! This is my first post, I'm so glad I found this forum because I just bought my first skid steer this week and have a ton of questions. I bought an older Case 1737 and have just gone through it and replaced radiator hoses, fan and alternator belts, changed the oil, put on some tire chains, and topped off the hydraulic fluid. The only problem now is that the right lift cylinder leaks pretty bad. The guy I bought it from gave me two seal kits for the lift cylinders but I'm not sure how to install them. It looks like there are four holes in the end of the leaking part where the gaskets go, do I need a special wrench to take apart the lift cylinder to rebuild it with the seal kit? Has anyone done this before, how difficult is it?
 

Tazza

Administrator
Staff member
Admin
Joined
Dec 7, 2004
Messages
16,694
All hydraulic rams are similar, Some have a clip in the end of the cylinder that holds the gland nut in place. MOST simply screw in, as you said there are 4 holes in the gland nut it should be screwed in. You need to either use a large pipe wrench on it or build a tool to remove it. The wrench will work, but will scuff the nut a fair bit.
Of course remove the cylinder first! then remove the nut.
Pull the ram stick out of the cylinder, you will then need to remove the piston from the end, these are pretty tight! that will allow you to slide the gland nut off the end where the piston was. You will need to use a pick to get the old seals out, note their directions!!! The pressure seal has like a “V” on one face, this must face the pressure side of the ram, the wiper faces our wards to keep dirt out. If they go in the wrong way they will not work. They can be a pig to get in, you need to twist them every which way to get them to locate in their grooves. Oil it all up and carefully push it back on the stick.
The piston seal should be done too, but depending on the type of seal dictates how it should be put on. Some are quite hard, others are a snap.
If you are concerned you can't do it your self, take them and the seal kits to a hydraulic shop,. they would assemble them for you.
They are very simple, but the pressure and wiper seals must go the correct way around or they will simply leak.
 

cchardwick

Well-known member
Joined
Jan 25, 2007
Messages
52
All hydraulic rams are similar, Some have a clip in the end of the cylinder that holds the gland nut in place. MOST simply screw in, as you said there are 4 holes in the gland nut it should be screwed in. You need to either use a large pipe wrench on it or build a tool to remove it. The wrench will work, but will scuff the nut a fair bit.
Of course remove the cylinder first! then remove the nut.
Pull the ram stick out of the cylinder, you will then need to remove the piston from the end, these are pretty tight! that will allow you to slide the gland nut off the end where the piston was. You will need to use a pick to get the old seals out, note their directions!!! The pressure seal has like a “V” on one face, this must face the pressure side of the ram, the wiper faces our wards to keep dirt out. If they go in the wrong way they will not work. They can be a pig to get in, you need to twist them every which way to get them to locate in their grooves. Oil it all up and carefully push it back on the stick.
The piston seal should be done too, but depending on the type of seal dictates how it should be put on. Some are quite hard, others are a snap.
If you are concerned you can't do it your self, take them and the seal kits to a hydraulic shop,. they would assemble them for you.
They are very simple, but the pressure and wiper seals must go the correct way around or they will simply leak.
OK, I'm going to give it a try. I do have another problem that I think is related. Every once in awhile when I lift the bucket with a full load of snow the lift speed slows way down and the lifting 'chatters'. But if I stop lifting and try it again it usually works great on the second try. Do you think that this is from one of the lift cylinders leaking? One leaks pretty bad, enough to drip down the side of the skid steer after a few hours, but the other side doesn't seem to be leaking. I tied a rag on the end of the cylinder to catch the fluid while I worked today and the leak really isn't too bad, about a tablespoon after several hours of plowing. Do you think the leak is making it occasionally chatter / slow down? Or is this another problem?
 

Tazza

Administrator
Staff member
Admin
Joined
Dec 7, 2004
Messages
16,694
OK, I'm going to give it a try. I do have another problem that I think is related. Every once in awhile when I lift the bucket with a full load of snow the lift speed slows way down and the lifting 'chatters'. But if I stop lifting and try it again it usually works great on the second try. Do you think that this is from one of the lift cylinders leaking? One leaks pretty bad, enough to drip down the side of the skid steer after a few hours, but the other side doesn't seem to be leaking. I tied a rag on the end of the cylinder to catch the fluid while I worked today and the leak really isn't too bad, about a tablespoon after several hours of plowing. Do you think the leak is making it occasionally chatter / slow down? Or is this another problem?
It could do. It may be letting air into the system that is causing the oil to foam up, this will cause chattering in the rams and loud noises from the pump.
Have you checked your oil level? if its leaking, you may have lost enough oil to make the system draw in air from the reserve tank. Usually a small leak will not cause a problem like this, but you never know.
 

cchardwick

Well-known member
Joined
Jan 25, 2007
Messages
52
It could do. It may be letting air into the system that is causing the oil to foam up, this will cause chattering in the rams and loud noises from the pump.
Have you checked your oil level? if its leaking, you may have lost enough oil to make the system draw in air from the reserve tank. Usually a small leak will not cause a problem like this, but you never know.
Here's an update: I took the cylinders off of the skid steer but could not get them apart. I ordered a spanner wrench from the dealer and it was the wrong size and had to send it back. So I bought a large pipe wrench instead and even with heating it with a propane torch and cranking on it with a four foot extension on the pipe wrench I just couldn't get it apart. So I took it to the dealer. He spent hours and it and charged me $250 (ouch) to put new seals in them. I talked to the guy who did it and he said that he broke his spanner wrench taking them apart WOW. He worked on it for some time with no luck and finally got his boss involved to help him. He finally heated it up with an acetylene torch, he said the propane torch wasn't hot enough. It looks like he heated it up red hot because all the paint was gone on the ends about four inches or so. He said he about knocked himself out when the spanner wrench broke LOL. I got them back on the machine and they seem to be working just fine! I talked to the guy who sold me the skid steer and he said that some people use lock tight on the threads making them impossible to get apart without high heat.
 

Tazza

Administrator
Staff member
Admin
Joined
Dec 7, 2004
Messages
16,694
Here's an update: I took the cylinders off of the skid steer but could not get them apart. I ordered a spanner wrench from the dealer and it was the wrong size and had to send it back. So I bought a large pipe wrench instead and even with heating it with a propane torch and cranking on it with a four foot extension on the pipe wrench I just couldn't get it apart. So I took it to the dealer. He spent hours and it and charged me $250 (ouch) to put new seals in them. I talked to the guy who did it and he said that he broke his spanner wrench taking them apart WOW. He worked on it for some time with no luck and finally got his boss involved to help him. He finally heated it up with an acetylene torch, he said the propane torch wasn't hot enough. It looks like he heated it up red hot because all the paint was gone on the ends about four inches or so. He said he about knocked himself out when the spanner wrench broke LOL. I got them back on the machine and they seem to be working just fine! I talked to the guy who sold me the skid steer and he said that some people use lock tight on the threads making them impossible to get apart without high heat.
Glad you got it all sorted out.
I guess some silly people could put loctite on the threads to prevent leaks but thats the job of the O rings, if you install them correctly loctite is not needed.
 
Top