642B steering help

Help Support SkidSteer Forum:

danman

Member
Joined
Nov 1, 2006
Messages
13
What a great forum I have been reading for 6 months or so lots of good info. I have a 642B that I rebuilt from the ground up original a gas motor installed an izuzu diesel in. approx 3000 hrs. on the machine. I will post some photos later. I noticed that the right drive side seems to be weak or not working properly. When I push the levers forward right side has power initially then seems to kick out like a pressure relief or something. It still has some power after that because it will move forward in a fairly straight line. It seem to operate better in reverse as well. any ideas ?
 

Tazza

Administrator
Staff member
Admin
Joined
Dec 7, 2004
Messages
16,697
Welcome to the forum.
In reverse, does it still seem to have plenty of power? if so, it could indeed be a problem with your relief valves in the hydrostatic pump. In one direction they should seal to hold the pressure and the other they open up. If you have full power in reverse and not forward i would say its not a problem with the pump its self, but the springs and poppet's that are in the pump housing.
 

danman

Member
Joined
Nov 1, 2006
Messages
13
Welcome to the forum.
In reverse, does it still seem to have plenty of power? if so, it could indeed be a problem with your relief valves in the hydrostatic pump. In one direction they should seal to hold the pressure and the other they open up. If you have full power in reverse and not forward i would say its not a problem with the pump its self, but the springs and poppet's that are in the pump housing.
Thanks for the quick response there seems to be more power in reverse because I can steer much better but it is hard to tell because only using the steering and not pushing with the bucket. Can the reliefs be cleaned ? is there anybody that has directions on taking them out?
 

Tazza

Administrator
Staff member
Admin
Joined
Dec 7, 2004
Messages
16,697
Thanks for the quick response there seems to be more power in reverse because I can steer much better but it is hard to tell because only using the steering and not pushing with the bucket. Can the reliefs be cleaned ? is there anybody that has directions on taking them out?
I'm at work at the moment, i can take a picture of the pake in my manual that shows the poppets.
It may not be junk stuck in it, it may have worn so it doesn't create a good seal any more. Either way, if you look at your hydro pump, where the 2 fat hoses join on each side you will notice i think 2 large bolt heads, say 1-1 1/2”. Behind here are springs and poppets. One side is for your charge oil, the other is relief, the problems is i can't remember which side is which. If you remove the plugs, do make sure you replace the O rings, there is up to 5,000 PSI behind these. You don't want them to leak.
Make sure you don't mix the springs up! only do one side at a time and you will be fine. The springs should be colour coded, this just indicates what the relief pressure is set to.
I will do my best to remember to take a pic of the page needed.
 
Top