853 Hydraulic problem

Help Support SkidSteer Forum:

GMIConst

Member
Joined
Nov 8, 2007
Messages
6
If I try to put pressure on the bucket to lift the front wheels off the ground, the hydraulics give out and the wheels come back down. I have put a new pump, new release valve, checked center spool, drained the lines. This didn't seem to fix the problem. Any other suggestions?
 

Tazza

Moderator
Staff member
Joined
Dec 7, 2004
Messages
16,840
Have you checked pressure at the quick couplers?
Is it only the lift that you have no power on or is it lift and tilt? You should be able to put the bucket on the ground and tilt forward and the front wheels should lift up no problems.
 
OP
OP
G

GMIConst

Member
Joined
Nov 8, 2007
Messages
6
Have you checked pressure at the quick couplers?
Is it only the lift that you have no power on or is it lift and tilt? You should be able to put the bucket on the ground and tilt forward and the front wheels should lift up no problems.
bucket tilts. front wheels do lift up but slowly come back down on their own. they won't stay up
 

skidsteer.ca

Well-known member
Joined
Jan 20, 2006
Messages
3,853
found your earlier post to the same problem about the anti cav valve. checking that next
A tilt cylinder packing would be the first thing to check. If you lif the bucket into the air with a load and see if it stays or leaks down. A packing can leak one try and not the next too. If you have changed the pump I would thing you would have tried this already??
Ken
 
OP
OP
G

GMIConst

Member
Joined
Nov 8, 2007
Messages
6
A tilt cylinder packing would be the first thing to check. If you lif the bucket into the air with a load and see if it stays or leaks down. A packing can leak one try and not the next too. If you have changed the pump I would thing you would have tried this already??
Ken
Put in a brand new tilt cyl
 

Tazza

Moderator
Staff member
Joined
Dec 7, 2004
Messages
16,840
Well, after $1400 and 10 hours of working on it...all it took was a $35 anti cav valve!
damn....
I can't see how the anti-cav valve could cause this problem....... I really need to remember this.
I guess at least its now fixed and with the new parts you put in they will not cause you any problems.
 

skidsteer.ca

Well-known member
Joined
Jan 20, 2006
Messages
3,853
damn....
I can't see how the anti-cav valve could cause this problem....... I really need to remember this.
I guess at least its now fixed and with the new parts you put in they will not cause you any problems.
The tilt cylinder could have been easily checked with compressed air to verify its condition.
Ken
 
Top