Thomas T-133 Bucket not tipping up

Help Support SkidSteer Forum:

russellb

New member
Joined
Apr 29, 2011
Messages
2
Hi there everyone I have a Thomas T-133 that has developed a hydraulic problem, The bucket will not tilt up, but has full operation for all other hydraulics (lift and tilt down). I have found a post here:
http://www.skidsteerforum.com/DesktopDefault.aspx?tabid=54&frmView=ShowPost&PostID=25963
That details the same symptoms, the suggestion is to find a faulty anti-cavitation valve. I have removed the cavitation valve from the main valve block under the seat but that looked fine to my untrained eye.
Is there a chance there may be more along the lines, and if so how would I find it? Unfortunatly the machine is a long way from anywhere so I cant really get anyone to look at it, any suggestions would be much appreciated.
Thanks Russell
 

russellb

New member
Joined
Apr 29, 2011
Messages
2
If its not the valves I suspect it must be the cylinder, any tips for removing the pivot pin on the bottom of the piston, it is seized good and nothing I can do will get it to budge
 

Tazza

Administrator
Staff member
Admin
Joined
Dec 7, 2004
Messages
16,697
If its not the valves I suspect it must be the cylinder, any tips for removing the pivot pin on the bottom of the piston, it is seized good and nothing I can do will get it to budge
You're talking about the eye of the ram rod?
You some times need to heat them to get it to free up, penetrating oil won't hurt either. Heat it and give it a good dose, leave it sit over night and see if it moves.
 

Latest posts

Top