Case 85xt problems

Help Support SkidSteer Forum:

Smokin S

Member
Joined
Apr 12, 2008
Messages
14
I have been having problems with the left side wheels not moving to creeping on a 1999 85 xt. If you play with the joystick for awhile you can usually get it to work like it should. This makes me think that i have a valve sticking. Anybody have any ideas where to start looking, as i will be fixing myself? Thanks Skyler
 

Tazza

Moderator
Staff member
Joined
Dec 7, 2004
Messages
16,819
I don't know if this setup runs straight levers with mechanical linkages to the pump....
Your best bet is to lift the cab and trace where the linkages go from the sticks to pump. If you say it works after fiddling i have to agree its a linkage issue. If it runs electric servo's, thats a little different...
 

goose

Active member
Joined
Apr 12, 2008
Messages
43
I don't know if this setup runs straight levers with mechanical linkages to the pump....
Your best bet is to lift the cab and trace where the linkages go from the sticks to pump. If you say it works after fiddling i have to agree its a linkage issue. If it runs electric servo's, thats a little different...
Tilt your cab forward and check the linkage going to your travel pumps while you move the levers and see if you have a ball joint worn out or loose ball joint mount that is letting the linkage move but not stroking the lever on the pump.
 
OP
OP
S

Smokin S

Member
Joined
Apr 12, 2008
Messages
14
Tilt your cab forward and check the linkage going to your travel pumps while you move the levers and see if you have a ball joint worn out or loose ball joint mount that is letting the linkage move but not stroking the lever on the pump.
Ok, ill check that today, but i think that is ok. I changed hyd filters. I bought it with this problem, used it 50 hours or so with it acting up but getting it to work right after messing with left side lever. Now i can't get it to work right at all. When i had problems and trying to get it to work it would break loose like turning a valve on and work just fine. I bought it from a dealer and they said it had a Relief valve or blow by valve sticking? I'm not sure what that actually said it was.
 

goose

Active member
Joined
Apr 12, 2008
Messages
43
Ok, ill check that today, but i think that is ok. I changed hyd filters. I bought it with this problem, used it 50 hours or so with it acting up but getting it to work right after messing with left side lever. Now i can't get it to work right at all. When i had problems and trying to get it to work it would break loose like turning a valve on and work just fine. I bought it from a dealer and they said it had a Relief valve or blow by valve sticking? I'm not sure what that actually said it was.
If your linkage is OK the next most comman area for problems is in the drive motor. There is a loop flush valve that can stick open and dump part of the high pressure oil and cause the drive to be weak and jerky. You can remove part or all of the valve without removing the motor. I will have to look in the book to see if this is the motor we can remove both halfs of the valve or not without removing the motor.
 
OP
OP
S

Smokin S

Member
Joined
Apr 12, 2008
Messages
14
If your linkage is OK the next most comman area for problems is in the drive motor. There is a loop flush valve that can stick open and dump part of the high pressure oil and cause the drive to be weak and jerky. You can remove part or all of the valve without removing the motor. I will have to look in the book to see if this is the motor we can remove both halfs of the valve or not without removing the motor.
How can i diagnose this problem forsure? Can i take a hose off and check the pressure with a gauge? And if so what should the pressure be? How big of a job is it to get to the drive motors?
 

goose

Active member
Joined
Apr 12, 2008
Messages
43
How can i diagnose this problem forsure? Can i take a hose off and check the pressure with a gauge? And if so what should the pressure be? How big of a job is it to get to the drive motors?
Another thought I have seen a couple of times Is the lever that is attached to the shaft going into the travel pump is splined to the shaft and may be stripped. you might check that before you dig into the motors. As far as checking the motors you can do a case drain test, There are 2 high presure lines going to the motor and a smallar one which is the case drain, Remove the hose at the motor and plug the hose. Install another hose on the fitting of the motor and stick it in a 5 gallon bucket. You need to block the machine up, tires off of the ground and disable the lockouts so you can run the drive. Run the side in question and see how much flow you get out of the hose into the bucket. You should get a steady trickle on a good motor if you get a steady 3/8 stream the motor is leaking internally. Check the motor in both directions. But check for the stripped shaft first.
 
OP
OP
S

Smokin S

Member
Joined
Apr 12, 2008
Messages
14
Another thought I have seen a couple of times Is the lever that is attached to the shaft going into the travel pump is splined to the shaft and may be stripped. you might check that before you dig into the motors. As far as checking the motors you can do a case drain test, There are 2 high presure lines going to the motor and a smallar one which is the case drain, Remove the hose at the motor and plug the hose. Install another hose on the fitting of the motor and stick it in a 5 gallon bucket. You need to block the machine up, tires off of the ground and disable the lockouts so you can run the drive. Run the side in question and see how much flow you get out of the hose into the bucket. You should get a steady trickle on a good motor if you get a steady 3/8 stream the motor is leaking internally. Check the motor in both directions. But check for the stripped shaft first.
How do i check the loop flush valve? I checked the ball joints on the levers today and they working good moving lever back and forth, i did't check to see if they shaft is stripped today, ill do that tomorrow. where are the wheel motors located, i did't look close enough today. What do you mean by disable lockout? Thanks again
 
OP
OP
S

Smokin S

Member
Joined
Apr 12, 2008
Messages
14
How do i check the loop flush valve? I checked the ball joints on the levers today and they working good moving lever back and forth, i did't check to see if they shaft is stripped today, ill do that tomorrow. where are the wheel motors located, i did't look close enough today. What do you mean by disable lockout? Thanks again
Where can i find a service manual for this machine?
 

goose

Active member
Joined
Apr 12, 2008
Messages
43
goose- any help on checking the loop flush valve? I looked tonight and found the drive motors. Where's a good place to source parts at?
As far as bypassing the lockout controls with the cab tilted up you will have to have the lapbar down, the seat switch bypassed and the cab down switch on the left rear corner of the cab bypassed. The seat switch you can jump with a wire, the cab down swtch can be held in with a magnet or a # 6 JIC cap. As far as a sorce for motor parts, your best bet is a Case dealer. Alot of the drive pump and motor parts Case has tied up so you have to get the from a dealer. Did you check the splines on the control lever? That still sounds suspect if you have no drive and the creep problem also.
 
OP
OP
S

Smokin S

Member
Joined
Apr 12, 2008
Messages
14
As far as bypassing the lockout controls with the cab tilted up you will have to have the lapbar down, the seat switch bypassed and the cab down switch on the left rear corner of the cab bypassed. The seat switch you can jump with a wire, the cab down swtch can be held in with a magnet or a # 6 JIC cap. As far as a sorce for motor parts, your best bet is a Case dealer. Alot of the drive pump and motor parts Case has tied up so you have to get the from a dealer. Did you check the splines on the control lever? That still sounds suspect if you have no drive and the creep problem also.
i did the case drain test today, i had a trickle no stream. i did it at idle and did't block the machine up either. What's the next thing to look at?
 

Tazza

Moderator
Staff member
Joined
Dec 7, 2004
Messages
16,819
Goose- any help now? or anybody else?
The only advise i can really give is to try swapping motors or if the hoses are close together on the pump swap them there. If the problem swaps sides you know its the motor, if not it sounds like a pump issue. There should be some plugs on the side of the pump, behind here you should have some relief valves and replenishing valves. Any of these could be the cause of your problem too. Its really hard to tell you whats wrong without seeing it, I'm sure you understand. They way you are talking it does seem to be something minor as after you jiggled the steering lever it does work so i would suspect the rotating groups and swash plates are still in good shape (the most expensive parts).
Have you harassed your dealer to see if they have a manual? they really are so helpful when you fiddle with things like this.
 

Trisimon

New member
Joined
Aug 15, 2020
Messages
1
Goose- any help now? or anybody else?
Hi Smokin S, I realize this is a party from 12 years ago, but I'm also having the same problem, same symptoms. Left drive not working until I give it full throttle and then it seems to break loose and everything runs normally, including parking brake on and off. If I shut off the engine and restart, back to stuck left side until I give it full throttle. I know it's not the parking brake or the drive chain. Seems to be, like you say, a stocking valve. Did you get the problem fixed? Thanks. Case 85XT.
 

Captain2100

New member
Joined
Feb 8, 2024
Messages
2
Hey I'm having the same problem with my 85xt and the dealership is giving me the runaround. What did you do to fix your problem?
 
Top