A300 Lift and Tilt Leakdown

Help Support SkidSteer Forum:

braxtonrosner

New member
Joined
Apr 10, 2024
Messages
2
Looking for some input on diagnosing a leak-down problem on a 2009 A300. Both the lift and tilt cylinders will leak down noticeably while operating the skid steer but stops when the lift bar is lifted which makes me believe it is not a cylinder problem. Also, if the arms are fully down and the stick is pushed forward, the bucket will slowly tilt down as well. I have changed the BICS pilot valve for the lift with no improvement. Thanks
 

brdgbldr

Well-known member
Joined
Jun 1, 2012
Messages
1,239
Definitely not a cylinder problem if it stops when the lap bar is up.

The lift and tilt could be a leaking relief valve. Or, less likely, bad check valves.

According to the parts manual, a new relief valves pressure has to be set on the machine. Hopefully just a new seal set on the valve will fix the problem.

Here is a link to the parts manual:

Just a heads up, I have 2005 A300 that slowly tilts down when the lift is all the way down and the stick is pushed forward. It stops as soon as I use the tilt. It's not bad enough to dig into the control valve but I have always figured that it has something to do with the relief valve sticking or internal seals on the valve leaking.

Keep us posted as to what you find.
 
Last edited:
OP
OP
B

braxtonrosner

New member
Joined
Apr 10, 2024
Messages
2
Definitely not a cylinder problem if it stops when the lap bar is up.

The lift and tilt could be a leaking relief valve. Or, less likely, bad check valves.

According to the parts manual, a new relief valves pressure has to be set on the machine. Hopefully just a new seal set on the valve will fix the problem.

Here is a link to the parts manual:

Just a heads up, I have 2005 A300 that slowly tilts down when the lift is all the way down and the stick is pushed forward. It stops as soon as I use the tilt. It's not bad enough to dig into the control valve but I have always figured that it has something to do with the relief valve sticking or internal seals on the valve leaking.

Keep us posted as to what you find.
When you say relief valve are you talking about the one on the very bottom of the block? I went ahead and pulled that one and put new seals in it and it showed no change. Any possibility there's a problem with the auto bucket level?
 

brdgbldr

Well-known member
Joined
Jun 1, 2012
Messages
1,239
If I remember correctly, there is only one relief valve. I don't remember the orientation. In the parts catalog it is oriented on the to in the schematic which means nothing as to how it is oriented in the machine.

I have not personally dealt with a bucket positioning circuit.

Since the lift and tilt are tied in together in the bucket positioning valve there definitely could be a problem there.
 

Latest posts

Top