743B Lift & Tilt barely work

Help Support SkidSteer Forum:

SAND

New member
Joined
Jul 18, 2006
Messages
2
My 743B lift and tilt can barely move up, and will not move down. It has done this twice before and magically recovered after sitting for awhile. This time however, it appears unable to recover. Hydrostatic drive works fine. Any suggestions as too what may cause this?
 

Tazza

Administrator
Staff member
Admin
Joined
Dec 7, 2004
Messages
16,697
Your aux hydraulics aren't locked in are they? check the right hand steering lever, it shouldn't be locked outwards. This is the most common cause of no hydraulic operation.
If that fails, it could be your relief valve in the control block. There may be some crap stuck in it causing you a lack of pressure build up.
Check the steering lever first, if not get back to me and i will tell you where to go hunting for your relief valve.
Good luck!
 

SAND

New member
Joined
Jul 18, 2006
Messages
2
Your aux hydraulics aren't locked in are they? check the right hand steering lever, it shouldn't be locked outwards. This is the most common cause of no hydraulic operation.
If that fails, it could be your relief valve in the control block. There may be some crap stuck in it causing you a lack of pressure build up.
Check the steering lever first, if not get back to me and i will tell you where to go hunting for your relief valve.
Good luck!
Tazza, Thanks for the advice. You are correct. The right hand lever was locked and when I pulled it out, everything worked fine. Thanks for the expert advice, you saved me a lot of trouble with a very quick solution. Sand
 

Tazza

Administrator
Staff member
Admin
Joined
Dec 7, 2004
Messages
16,697
Tazza, Thanks for the advice. You are correct. The right hand lever was locked and when I pulled it out, everything worked fine. Thanks for the expert advice, you saved me a lot of trouble with a very quick solution. Sand
Excellent!
Glad i could help
 
Top