TL12v2 Overheating Issue

Help Support SkidSteer Forum:

Boston3220

New member
Joined
Apr 14, 2024
Messages
1
I have a TL12v2 that's three years old with 350 hours on it and is used strictly for ranch use. The engine overheats whenever I'm running the brush cutter after about 15-20 minutes. The warmer the weather the quicker it overheats. I have to shut down the brush cutter and wait about 5 minutes for the overheat buzzer to stop and cool down enough to start shredding again for about 5 minutes before the engine coolant temp goes into the red and the buzzer and red warning light come on again. The hydraulic oil temp never goes above the bottom green peg. I pressure wash the radiator fins on a regular basis but it still overheats when using the brush cutter. The radiator is full of coolant and the brush cutter is turning in the correct counter clockwise direction. The dealer has no clue what the problem is. Could the radiator possibly be plugged from the front (engine) side?

Any thoughts or suggestions?
 

tmts

New member
Joined
May 29, 2024
Messages
1
Did you ever figure out your issue? Dealing with the exact same symptoms on my 2018 tl12 while mulching even has external cooler
 

foton

Well-known member
Joined
Mar 1, 2018
Messages
1,345
I do not know about your machine but does it have a thermostatically controlled fan that maybe is not kicking on to cool your hydros. system ? It could be nuttin but a blown fuse or bad relay. or thermo switch. just a guess
 

Centexequipment

Active member
Joined
Dec 13, 2023
Messages
41
Use a flashlight one one side of the radiator and look on the other side of the radiator if you can see light is clean. You'll have to look at the whole radiator this way. Those tend to clog up on the edges of radiator first so I would start there
 
Top