Thomas t-133 with v1902b kubota engine problems

Help Support SkidSteer Forum:

RobMonk

New member
Joined
Dec 17, 2013
Messages
1
I have had my old Thomas for about 9 months now and I have been enjoying it, I don't use it all that frequently so I have a hard time gauging if changes happened over a long period or over night. Yesterday I was using it to dig out of a big snow storm and I noticed it was making a sort of knock but I would call it more of a 'ticking'. It sounded like it was small/light pieces creating the issue, in fact I checked several times to see if it was the fan hitting the shroud. The ticking increased with RPM but after a while I just figured that I didn't notice it before because I always wear hearing protection. It seemed to have a bit of an issue reaching full power but it did the job. Today I jumped into it to do a neighbors driveway and I got it all done (10minutes) and just at the end the sound disappeared and there was more vibration and seemingly less power. I turned it off immediately to check to see if perhaps the serpentine broke (as I suspected the fan as the noise culprit) It wasn't broken and so I decided I would start it and make a B-line for home. It wouldn't start as the starter had a hard time turning it over. I have been experiencing this lately and if I let it sit for 10 mins or so it starts no problem. Anyhow I got it home and the engine seems to be shaking quite a bit which I would guess as on cylinder not firing and so when it was cooled down I put a pile of snow on each of the exhaust manifold legs and 3 of them melted near immediate and the 4th took a while to melt and then stayed wet for a few minutes while the others were dry as a bone. So. I am thinking injector nozzle? But I'm not sure that explains the ticking from earlier and does it make sense that would stop working in an instant? Thinking about it, I did notice an increase in the amount of smoke coming out of the stack before it broke. If it is that, is there a way to test the injector to verify that? My friend works with diesel engines and his work has an injector crew that handles the testing of injectors but he doesn't know how it is done himself but the tech is available to him. I am guessing he would need specs? Has anyone had experience with replacing injectors on these engines (or similar engines)? Is it a big job or as quick as it looks? Any suggests would be appreciated
 

Tazza

Administrator
Staff member
Admin
Joined
Dec 7, 2004
Messages
16,697
If it's not cranking properly, i don't believe it is an injector issue.
Check that the aux hydraulics are not stuck on loading the engine down.
If it's not, i'd slide the engine back a little to disengage the connection between the engine and pump. This will show you what part is tight, the engine or pump.
 

Latest posts

Top