Bobcat 751 drive belt problem

Help Support SkidSteer Forum:

Callum

Member
Joined
Oct 24, 2023
Messages
7
Hi,
I am trying to replace a drive belt.
I removed the broken one and lowered the tensioner to its limit and tried to put the new belt in.
There just isn't enough free play to get the belt around all three pulleys.
I then took the tensioner out and easily fitted the belt but then the bulky tensioner won't fit back in place.
I can't believe it should be this hard, so I'm obviously missing something. I just can't see what. I've looked for a video clip of the process but can't find one for a 751.
I'd appreciate any help I can get.
Thanks.
 

Tlawdogg

Well-known member
Joined
May 22, 2020
Messages
76
Confirm the "New" belt is the same size as old one? I did not check before I dove into my belt change.
Bobcat sold me a belt and I had the same issue (on a 863). Turns out it was the wrong size belt , like 2 inches too short..
 
OP
OP
C

Callum

Member
Joined
Oct 24, 2023
Messages
7
Confirm the "New" belt is the same size as old one? I did not check before I dove into my belt change.
Bobcat sold me a belt and I had the same issue (on a 863). Turns out it was the wrong size belt , like 2 inches too short..
Thanks, yes I checked it beside the original belt, same size.
 

Tlawdogg

Well-known member
Joined
May 22, 2020
Messages
76
Ok, I am at a loss since I have a 863.
On mine I remember putting the front part on first. Then rear. Make sure pulleys are clear of debris, sticks, old belt pieces ect. Then on tensioner. Hopefully someone with a 751 will chime in....
Here is a picture of when I put drive belt on.
 

Attachments

  • Screenshot_20231129_100707_Gallery.jpg
    Screenshot_20231129_100707_Gallery.jpg
    454 KB · Views: 26
Last edited:
OP
OP
C

Callum

Member
Joined
Oct 24, 2023
Messages
7
IMG_2511.jpeg

Here are some pics of the area
 

Attachments

  • IMG_2509.jpeg
    IMG_2509.jpeg
    647.5 KB · Views: 34
  • IMG_2510.jpeg
    IMG_2510.jpeg
    562.2 KB · Views: 32

brdgbldr

Well-known member
Joined
Jun 1, 2012
Messages
1,113
Not sure it would even be possible, but check to make sure that your pump and or engine haven't come loose and slipped out of alignment.
 
Top