943 problem

Help Support SkidSteer Forum:

Tschoollie

New member
Joined
Feb 10, 2008
Messages
1
I recently bought a 943 and the right side wheels are starting to slow down compared to the left. It seems to be the same in forward and reverse. If I drive with both sides equally it runs ok but does turn slightly to the right. Could anybody give me some advise? Also I was planning on changing the fluids and someone suggested torque fluid instead of regular hydrolic fluid. Is that a good idea?
 

Tazza

Moderator
Staff member
Joined
Dec 7, 2004
Messages
16,844
It sounds like the pump or the motors are starting to wear. You can try swapping drive motors and see if the problem changes sides, if so you have a motor issue.
Its normal for you not to notice lower power when driving in a straight line as there is a much lower force on the motors then.
 

skidsteer.ca

Well-known member
Joined
Jan 20, 2006
Messages
3,853
It sounds like the pump or the motors are starting to wear. You can try swapping drive motors and see if the problem changes sides, if so you have a motor issue.
Its normal for you not to notice lower power when driving in a straight line as there is a much lower force on the motors then.
If the power is good, but the speed in not keeping up on one side , it could just be a simple problem with slack or play in the linkages from the steering lever to the hydrostat, preventing the hydrostat from seeing full speed.
If that side is feeling weak ( and is slow both ways) and does not wnt to spin the tires, and the problem get more noticable as the loader (many the hydraulic oil) warms up then it is most likely in the motor or hydrostat, and swaping motors side to side is a good way to test for motor wear.
Ken
 

riccardo

New member
Joined
Feb 11, 2008
Messages
1
hi i bought a used skid steers, they did not give me a istruction for the pression and all information . do you know where i can find it? my model is compact loader sid steer 773 thank you
 
Top