Recent content by CLi87

Help Support SkidSteer Forum:

  1. C

    Mustang 320 Hydrostatic Shift Cable?

    Thanks!! btw how did you find the part #? I looked everywhere and couldn't find a diagram or anything, or perhaps I should look for the Gehl or John Deere version instead of the Mustang version?
  2. C

    Mustang 320 Hydrostatic Shift Cable?

    Well this is my luck, got my engine running great, new belt put on, and then my shift cable for the hydrostatic drive just broke...Anyone know where to get one? The cable that connects from the shifter to the pulley to engage the hydrostatic drives.
  3. C

    Mustang 320 drive belt

    Thanks so much! Just ordered one :)
  4. C

    Mustang 320 drive belt

    I'm in the same boat, after re-installing my engine my double v-ribbed drive belt broke into 2 pieces, also having a hard time finding a belt. Mine was 52" x 1" wide but can't seem to find any double v-ribbed belt with those specs.
  5. C

    What kind of Onan engine is this?

    Thanks guys! I got the engine freshened up with a valve adjustment and de-carbonization, new gaskets all around of course as well, she runs great now! But I seem to have another problem, the drive belt shredded, not sure why, I thought I had the engine aligned properly with the hydrostatic...
  6. C

    @ Administrator or Moderator

    I believe I had the same problem on both chrome browser on computer and chrome browser on android.
  7. C

    What kind of Onan engine is this?

    Hey all, just bought a OMC Mustang 320 skid steer, I want to do a complete service to the motor but can't figure out what Onan engine it is, I was told by the previous owner it's a 25hp Onan, I figure it's a B series engine since there's no oil filter and I have points ignition, but can't figure...
  8. C

    @ Administrator or Moderator

    Just an FYI to the admin or moderators, it took me forever to register for this site because the ad at the bottom of the page prevents you from clicking the submit button on the registration page, I had to install custom ad-blockers in order to register, I'm sure others are having this problem...
Top