Search For SkidSteer Related Info on The Web 



  We Accept Donations! 

If you enjoy what we have to offer or this site has helped you along the way, please consider a donation to help us defray the cost of development and hosting! Thanks



The safer, easier way to pay online!



  The SkidSteer Forum 

   
Forums Home   Search   Login   Register   Member List  

Bobcat  > Skid Steers  > Bobcat t190 Glow Plug Problem  
 
Display using:  
Previous Thread :: Next Thread 
 Author Thread: Bobcat t190 Glow Plug Problem
ECLC is not online. Last active: 12/13/2010 8:32:21 PM ECLC
Joined: 09 Dec 2010
Total Posts: 2
 
Bobcat t190 Glow Plug Problem
Posted: 12/09/2010 04:03 PM
I have a Bobcat t190 with a glowplug problem. They work perfect untill it gets around 60 degrees or lower outside they dont work witch is when you need them most. When i turn the key it will come up with the normal coundown from 19 seconds but then it stops counting down and the glowplug light blinks on the right pannel. The dealer has no idea what it could be. Thanks in advance for any help.
Tazza is not online. Last active: 11/20/2014 1:48:51 PM Tazza
Top 25 Poster
Forum Moderator
Joined: 08 Dec 2004
Total Posts: 11835
 
Re: Bobcat t190 Glow Plug Problem
Posted: 12/12/2010 04:39 PM

Have you checked the usual things?

Make sure the plugs are in good order, check the relay?


Bobcat 763 burntSadbut i'm working on it!, 04 S150 with air and a smooshed cab, S250 turbo.
ECLC is not online. Last active: 12/13/2010 8:32:21 PM ECLC
Joined: 09 Dec 2010
Total Posts: 2
 
Re: Bobcat t190 Glow Plug Problem
Posted: 12/13/2010 08:32 PM
Thanks for the help. I pulled off the cover for the fuse box and everything was corroded the rubber seal went bad and left in moisture. I cleaned and greased all the relays and fuses and now it works perfect. That saved me some money the dealer wanted me to bring it in so they could put it on the computer.
Tazza is not online. Last active: 11/20/2014 1:48:51 PM Tazza
Top 25 Poster
Forum Moderator
Joined: 08 Dec 2004
Total Posts: 11835
 
Re: Bobcat t190 Glow Plug Problem
Posted: 12/14/2010 02:14 PM
Glad you found the problem, the fues box always seems to attract moisture causing corrosion.

Bobcat 763 burntSadbut i'm working on it!, 04 S150 with air and a smooshed cab, S250 turbo.
Previous Thread :: Next Thread 
Page 1 of 1
 
Forums  > Bobcat  > Skid Steers  > Bobcat t190 Glow Plug Problem  
   
(Copyright 2002-2010) Owens Consulting
*
Powered by E-SpiritLink    Terms Of Use    Privacy Statement
Portal engine source code is copyright © 2002-2014 by DotNetNuke. All Rights Reserved