Search For SkidSteer Related Info on The Web 


  We Accept Donations! 

If you enjoy what we have to offer or this site has helped you along the way, please consider a donation to help us defray the cost of development and hosting! Thanks



The safer, easier way to pay online!




  The SkidSteer Forum 

   
Forums Home   Search   Login   Register   Member List  

Bobcat  > General Repairs  > Re: bobcat 642 governor trouble  
 
Display using:  
Previous Thread :: Next Thread 
 Author Thread: bobcat 642 governor trouble
FLYERME is not online. Last active: 6/14/2008 11:08:25 AM FLYERME
Joined: 17 May 2008
Total Posts: 5
 
bobcat 642 governor trouble
Posted: 05/17/2008 06:53 PM
Im a newby. I have recently purchaced an old melroe bobcat 642 ,has a ford 1.6 cross flow engine. I noticed the goveror was not working and when I pulled it apart I descovered it had practicly no oil in it! I checked seal bearings and throw mechanism all seem fine and in perfect working order.(seems to be a very simple unit) I refilled the governor put it back on and tried it and still nothing? I then adjusted the throttle/governor linkage as the manual specifies and still nothing. I've had to resort to adjusting the restrictor screw so I can bring the revs up to around 2500rph as aposed to the 1000-1500 I was getting? so dose any one have any ideas why my governor still wont work? wondering if it could be the spring? Has a bit of wear in the spring attatching holes. frustrating ! p.s compression test O.K
thetool is not online. Last active: 6/16/2009 12:11:14 AM thetool
www.compactequipmentservice.com
Top 25 Poster
Joined: 22 Mar 2008
Total Posts: 516
 
Re: bobcat 642 governor trouble
Posted: 05/21/2008 04:28 PM

My guess is it went dry, siezed and snapped the main shaft, or the weights are siezed in the high-speed position if the engine is running away.

I wonder what a new one costs?

Good luck


The Tool aka Shane www.compactequipmentservice.com .
FLYERME is not online. Last active: 6/14/2008 11:08:25 AM FLYERME
Joined: 17 May 2008
Total Posts: 5
 
Re: bobcat 642 governor trouble
Posted: 05/28/2008 03:24 PM
No it had some dregs (oil) left in it. bearing,shaft,throw mechanism,weights ect are all in good working arder can find no internal fualt.Have filled oil to level and nothing,if I manually push the governer linkage engine revs up fine. I thinking of trying a thicker oil? It seems when it bogs down the weights are still out so the oil is not closing them to bring up the revs.im not sure what oil is ment to be in it so im just guessing.
jerry is not online. Last active: 9/1/2014 3:53:39 PM jerry
Top 25 Poster
Joined: 03 May 2007
Total Posts: 1750
 
Re: bobcat 642 governor trouble
Posted: 05/28/2008 05:54 PM
I have the ford engine in a 632, I am not sure it is the same as yours but when I got the machine the governor did not respond good. After replacing the vacuum advance and setting the timing it works fine. be sure to check the vacuum advance on the distributor to see if it is leaking and also the centrifugal advance in the base of the distributor. If the timing is wrong it will not respond as it should. When you move the throttle lever it has to move the spring connected to the governor rod which is connected to the carb butterfly. What happens when the throttle lever is moved? My book does not show the internal of the governor but maybe the dealer has a exploded view you could look at, might be a spring missing in there. If anything I think the oil should be thin so there is less resistance as the weights try to close. good luck

LX665,backhoe,snowplow,assorted homemade stuff Northeast Mn
Previous Thread :: Next Thread 
Goto to page:  Prev Next
 
Forums  > Bobcat  > General Repairs  > Re: bobcat 642 governor trouble  
   
(Copyright 2002-2010) Owens Consulting
*
Powered by E-SpiritLink    Terms Of Use    Privacy Statement
Portal engine source code is copyright © 2002-2014 by DotNetNuke. All Rights Reserved